라이믹스

Rhymix.png


-

Rhyme + Remix = "RHYMIX"!

라이믹스 공식 홈페이지 깃허브 저장소

정보

XE를 포크(fork)하여 진행중인 PHP 기반의 오픈소스 CMS(Contents Management System)으로, 기반 CMS인 XE보다 활발하게 프로젝트가 운영되고 있다. 기존의 XE가 보안패치만 진행하고 쌓여 있는 수많은 개선사항들은 추가되지 않아 XETown 커뮤니티를 중심으로 만들어졌다.

XE에서 분기했을때 임시로 썼던 이름은 XETOWN Fork, XETOWN REMIX(XTR)라고 불렸다.[1] 토론을 통해 라이믹스(Rhymix)로 이름을 정했다.

라이믹스는 시급한 버그, 보안패치를 우선적으로 패치하며 보안패치로 명을 잇고 있는 XE와 호환되지만 더 빠르고 편한 환경을 만들어 가고 있다.

위의 내용들을 정리하자면 XE의 개선버전이라 할 수 있다.

라이믹스의 버전

라이믹스는 정식 버전이 존재하지 않는다 그렇기 때문에 라이믹스 1.9.x 버전과 같이 뒤에 버전을 붙히는게 무의미하다.

전에는 XE 1.9 버전까지는 XE의 버전을 따라갔지만[1], XE가 1.11 버전을 릴리즈 할 때부터는 라이믹스는 1.9 버전을 이어가고 있다.

자체 버전?

  • 기존에는 XE의 버전에 맞추어 버전을 올렸으나, XE 1.10버전부터는 xe의 버전에 맞추지 않고, 자체 버전을 부여하여 진행한다. XE의 1.10 버전이 취소됨에 따라 평소와 같이 진행된다.

변경사항

  • https://xetown.com/rxe_issue/995249 xe의 1.10 버전 취소와 상관 없이 아래의 변경사항은 적용된다.
  • 결국 라이믹스를 사용하기 위해서는 반드시 php 7.0 이상으로 업그레이드를 하자.

1. DB 지원 축소

2. DB 접속 방식 축소

  • mysql 방식으로 접속하는 경우, 자동으로 mysqli 방식으로 접속 방식 변경.

3. (중요) 지원 PHP 버전 변경

  • php 7.0 이상만 사용이 가능.

4. xcache 지원 중단.

  • php 7.0에서는 xcache가 작동하지 않으므로, xcache의 지원 중단함.

5. 기타 자세한 내용은 라이믹스 버전 및 PHP 버전 변경 예고 글을 참고하자!

최소사양

라이믹스의 최소사양은 라이믹스/사양 문서에 적혀져 있다. 문서에 적혀져 있는 최소사양을 넘기지 못한 경우, 특히 PHP 버전을 넘기지 못하는 경우에는 러이믹스를 사용 할 수 없다.

최소사양은 XE보다 높기 때문에 XE에서 넘어오는 경우 반드시 확인해 보자!

XE에서 넘어오는 방법

XE에서 라이믹스로 넘어오기 전에 가장 먼저 해야 할 것은 바로 백업! XE가 설치된 폴더[2]와 DB를 백업하자!

그 다음 라이믹스 파일을 통째로 덮어쓰기 하면 된다. XE와 달리 일정 주기로 올라오는 것이 아니기 때문에 이전할때 라이믹스 깃허브에서 최신버전을 다운로드 받아 덮어쓰면 된다.

이전하기 전에 고민을 하고 이전하자. XE에서 라이믹스로 넘어오면 다시는 XE로 되돌아 갈 수 없다. 왜냐하면 XE와 라이믹스의 구조가 다르기 때문이다.[3]

업데이트 방법

러이믹스 뿐만 아니라 모든 소프트웨어들은 업데이트를 꾸준히 해야 한다. 특히 라이믹스는 XE와 달리 수시로 올라오기 때문에 자주 업데이트를 하는 습관을 기르는 것이 좋다.

더욱 더 자세한 내용은여기에서 확인하자.

git 이용

라이믹스를 git으로 clone한 경우는 간단히 git 명령어로 럽데이트를 할 수 있다. 라이믹스가 설치된 폴더로 이동한 뒤, 아래와 같이 입력한다.

git pull

FTP 덮어쓰기

git을 사용 할 수 없는 경우에는 FTP를 통해 덮어써야 한다. 자신이 사용하고 있는 브랜치를 확인 후, master 브랜치,develop 브랜치 사용하고 있는 브랜치에 맞게 다운로드 받은 뒤, 압축 해제 후 ftp로 파일들을 업로드한다.(덮어쓰기)

XE와의 차이점

  1. XE와 라이믹스는 여러 부분에서 차이점이 존재한다.
  2. 자세한 내용은 라이믹스/XE와의 차이점 문서를 참고하자.

버그

  1. 자세한 내용은 라이믹스/버그 문서를 참고하자.
  2. 버그가 발생했다면 깃허브 이슈로 이슈를 알리자. 만약 보안 버그라면 깃허브가 아닌 [email protected]로 보내자.
  3. 또한 버그 뿐만아니라 개선사항이 있는 경우에도 깃허브 이슈로 알리면 처리해 준다.

XE Admin Help

  1. 라이믹스 관리자 페이지(/admin)에서 (?) 버튼[4]을 클릭하면, 'XE Admin Help' 문서가 나온다.
  2. XE 1.7 버전의 정보이므로 라이믹스에서 참고하기에는 어렵다.
  3. 그렇기 때문에 라이믹스에 맞춘 라이믹스 문서 수정본 저장소가 있다. 많이 부족하지만 기존에 있던 것 보다는 훨씬 보기에 좋다.

라이믹스 블랙리스트

라이믹스에서 일부 XE 서드파티들(모듈, 애드온 등)을 사용 할 수 없다. (블랙 리스트는 이곳에서 확인 가능하다.)[5]

라이믹스에 블랙리스트가 있는 이유는 이미 라이믹스에 해당 기능이 구현 되어 있거나, 호환성에 문제가 있어서 블랙리스트로 관리되며, 설치는 되지만 작동하지 않는다.

무분별한 블랙리스트 남용을 방지하기 위해 블랙리스트에 등재가 된 서드 파티들은 라이믹스 코어의 기능과 충돌하여 다른 기능의 정상 작동마저 방해하는 상황에만 등재된다.[6][7]

이러한 이유로 텍스타일이나 포크 버전인 업글타일은 비록 라이믹스에서는 사용이 불가능하지만, 블랙리스트에는 등재 되지 않았던 것이다.

물론 텍스타일이나 업글타일 같은 블랙리스트에 등재 되지 않은 일부 특수한 케이스의 서드 파티들을 라이믹스에서 100%(?) 사용 할 수 있다는 것은 아니다. 꼭 사용하고 싶다면, XE 1.5 버전에서 파생된 다올 CMS를 사용하자.[8]

편법을 통해 사용할 수는 있지만 권장하지 않는다. 어떠한 버그가 발생할지는 아무도 모른다.

다음 하위 문단에 블랙리스트에 오른 XE 모듈/애드온들이 있다. 만약 XE에서 라이믹스로 넘어오고 싶은 경우 아래의 서드파티들이 있는지 확인 후 사용하자.

모듈

  1. 멀티 도메인 모듈
  2. 자동 로그인 모듈
  3. 세션 쉴드 모듈
  4. CafeXE 모듈
  5. XE SEO 모듈

애드온

  1. 멀티 도메인 애드온
  2. 언어 자동 선택 애드온
  3. UTF-8 이모티콘 지원 애드온
  4. jQuery CDN for XE 1.7 애드온
  5. ZipperUpper! 애드온

여담

여담으로 라이믹스 커뮤니티인 XETOWN에 이 문서에 대한 글이 올라왔다! XETOWN - 라이믹스를 나무위키보다 더 자세하게 기재된 곳을 발견..

기진곰님은 해당 글의 댓글에 "저걸 그냥 공식 매뉴얼로 써도 되겠는데요? ㅋㅋㅋ" 라고 적었다.

-

이러다가 이 문서가 공식 매뉴얼로 쓰일지도?!!

 
— 김칫국 원샷중인 관리자

사용처

  1. 모든 사용처를 적을 수 없으므로, 몇개만 나열한다.

각주

  1. XE와의 호환성을 위해 버전을 부여한 것일 뿐이다. 깃허브 참조
  2. 이때 파일 퍼미션을 동일하게 해야 한다. 리눅스인 경우, tar cvfpz 압축파일명.tar.gz 폴더명 형식으로 백업 할 수 있다. 예: tar cvfpz html.tar.gz html
  3. 이전하기 전에 사용하는 서버가 라이믹스 최소사양을 충족하는지 확인해 보도록 하자.
  4. 정확하게 말하자면 원 안에 물음표가 있는 버튼
  5. 기진곰님의 자료들이 왜 많지?
  6. 깃허브 이슈 - 기진곰님 답변
  7. 일관성 있게 적용되는 것은 아니지만 블랙리스트에 등재된 서드 파티들은 대부분 코어에 흡수되어 있다.(기진곰님 답변 중...)
  8. 왠만하면 이러한 서드 파티들을 놓아주자. 거의 회생 불가능하기 때문이다.